Microsoft Catalog download error for recent OOB updates

Steven Gallagher 1 Reputation point
2022-01-19T13:05:44.66+00:00

I am trying to download the January 2022 OOB updates to import to our WSUS server, as these updates are not being released to WSUS directly.

I have tried downloading KB5010790, KB5010791, KB5010794, KB5010797 & KB5010798 from the Microsoft Catalog using Microsoft Edge and when the download begins the file is marked with a red X in the Downloads section of Edge, the usual download progress does not display but, you can see a progress indicator on the Microsoft Edge icon in the taskbar, however, the end result is that only a CRDOWNLOAD file is received and the full .msu file is not downloaded.

I have tried InPrivate Window and that gives the same result.

With Google Chrome the download link results in nothing happening.

I am able to download other files without any issue so, this does not appear to be a client side issue.

Not all our servers have internet access by design so, it is not possible to download from Microsoft Update and unfeasible to start opening access temporarily.

Anyone else seeing this issue and found a way around it?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,263 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Dave Patrick 426.2K Reputation points MVP
    2022-01-19T13:58:00.03+00:00

    A lot of the Jan 11th updates were pulled because of problems with the updates.
    https://learn.microsoft.com/en-us/windows/release-health/status-windows-10-1809-and-windows-server-2019

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  2. Steven Gallagher 1 Reputation point
    2022-01-19T14:11:46.45+00:00

    Seems like this is happening for any download from the catalog currently, the updates are being detected as unsecure and the answer is to select Keep in Edge. You can should then be able to refer to the KB article and check the hash value to be secure.


  3. Dave Patrick 426.2K Reputation points MVP
    2022-01-19T14:13:41.677+00:00

    Hmm, Ok, have not had this experience. You might try downloading from another desktop as a test.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


  4. cpc-tr 1 Reputation point
    2022-01-20T14:04:10.143+00:00

    I had the same problem with any files from the catalog, but Firefox gave me an "Allow" choice that let me download anyway.

    Firefox has a new feature to block or warn of insecure downloads, but it looks like the MS Catalog site certificate is valid. Firefox isn't giving me the error for other downloads from valid https sites, so maybe there's something wrong behind the scenes at the MS catalog site.

    0 comments No comments