How to enter MPN ID for App Registration?

Erwin Sinniah 21 Reputation points

I am in the process of App Registering, Branding and properties, Publisher Verification. When I try to enter my MPN ID, I keep getting an error "You must use multi-factor authentication to proceed. Please ensure MFA is enforced for your account, and then sign in again using MFA. Click for additional information." I have tried to sign in with MFA and yet it still does not work. How do I enter the MPN ID, with MFA or how do I ensure I have MFA?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,436 questions
0 comments No comments
{count} votes

Accepted answer
  1. Marilee Turscak-MSFT 33,801 Reputation points Microsoft Employee

    Hi @Erwin Sinniah ,

    There are a few things to check:

    Make sure that MFA is enabled on the account. If you are the admin of the account, you can follow the steps to enable MFA or make sure that security defaults are enabled. You can then go to to configure your MFA methods.

    Then, I would double check that your MPN associated with Azure AD and the current directory are same. You cannot associate an MPN with different directory other than one approved.

    As long as you created the App Registration where the domain is primary domain (used to verify MPN ID in the Partner Center), and enabled MFA for the user who is trying to add MPN ID to Application, you should be able to resolve this issue.

    I don't think this applies to your situation based on the error message you included, but I will also note that you can get blocked if your account has been identified as a "risky user." If the user is on the “risky users” list, you or your admin may need to perform remediation steps to eliminate user risk. Reference: Remediate risks and unblock users in Azure AD Identity Protection | Microsoft Learn. After remediating, it will take several hours to invoke dismiss process in our backend, and then you can try adding the MPN ID again.

    Let me know if these steps help.


0 additional answers

Sort by: Most helpful