PS Remoting using GPO

Manish Chawda 426 Reputation points
2022-01-21T14:07:08.897+00:00

Hi,

I have Windows Server 2019 and Workstation are Windows 10 / 11.
I want to login remotely to Workstation using Powershell Remoting in GPO . I tried but could not do it.

Kindly advise

Manish

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,724 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 39,336 Reputation points
    2022-01-21T22:50:55.29+00:00

    Hello @Manish Chawda

    • > Enable Windows Remote Management
      Computer Configuration > Policies > Administrative Templates: Policy definitions > Windows Components > Windows Remote Management (WinRM) > WinRM Service.
      Right-click on Allow remote server management through WinRM and click Edit, type the IP address of the certain IP address only=> Apply this to all the computers that we need to connect remotely.
    • > Configure Windows Firewall Settings =>Apply this to all the computers that we need to connect remotely.
    • > Configure Windows Remote Service on this computer of the certain IP address only and all the computers that we need to connect remotely
    • > Run winrm qc on this computer of the certain IP address to see if we receive any message.

    Reference:
    Installation and Configuration for Windows Remote Management
    https://learn.microsoft.com/en-us/windows/win32/winrm/installation-and-configuration-for-windows-remote-management

    Enable-PSRemoting
    https://learn.microsoft.com/en-us/powershell/module/microsoft.powershell.core/enable-psremoting?view=powershell-7.2

    Hope this helps with your query!


    --If the reply is helpful, please Upvote and Accept as answer--


  2. Manish Chawda 426 Reputation points
    2022-01-31T13:00:25.963+00:00

    Any idea of PSRemoting using SSH in GPO ?

    0 comments No comments