Error adding tag to Azure Container Instance

Dave Gill 1 Reputation point
2022-01-21T15:38:45.273+00:00

Hi, I have a release pipeline that creates and tags ACIs using PowerShell, yesterday it suddenly started to fail on the task that adds the tags. I've investigated by trying to manually tag the ACI (the resource is created succesfully) via PowerShell and the Portal. I always get the same error.

{
"details": [
{
"code": "ProviderError",
"message": "{\"error\":{\"code\":\"InternalServerError\",\"message\":\"Encountered an internal server error. The tracking activity id is 'xxx', correlation id is 'xxx'.\"}}"
}
]
}

I've can still tag other types of resource in Azure, I've tried tagging other ACI instances in the same region (UK South) and that also fails, I can however add a tag to an ACI in different region (North Europe).

For testing I've tried setting the tag name and value to 'test', it still doesn't work.

Is anyone else experiencing similar issues or can help?

Thank you.

Azure Container Instances
Azure Container Instances
An Azure service that provides customers with a serverless container experience.
630 questions
{count} votes

1 answer

Sort by: Most helpful
  1. kobulloc-MSFT 23,106 Reputation points Microsoft Employee
    2022-01-21T21:05:45.497+00:00

    Hello, @Dave Gill !

    I reached out to the product group and we'd like to investigate this further as it appears to be an issue on our end but we aren't seeing anything that would cause an outage for UK South. I'll follow up with you directly for more details.

    Edit

    Issue:
    Attempting to add a tag to an Azure Container Instance results in an error:
    "Encountered an internal server error. The tracking activity id is 'xxx', correlation id is 'xxx'.\".

    This may happen using multiple approaches (Azure Portal and PowerShell) and is limited to a specific region.

    Resolution:
    It appears that this may have been a brief issue on our end that has since been resolved. If you run into this again, please let us know.