Windows 10 update error 0x80244018​. Unable to update.

Sherri Khan 31 Reputation points
2022-01-22T08:02:03.787+00:00

When trying to update to the latest Windows 10 version in Windows update, the system shows "There were problems installing some updates, but we'll try again later" as the installation process reach 100%. The error code is 0x80244018. I have tried various methods to solve this problem, But no method is working anymore.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,084 questions
Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,747 questions
0 comments No comments
{count} vote

Accepted answer
  1. Limitless Technology 39,336 Reputation points
    2022-01-25T14:30:47.877+00:00

    Hello @Sherri Khan

    The error 0x80244018 also comes with the error message WU_E_NO_USERTOKEN. So error code 0x80244018 may be caused by various reasons:

    • > The third-party application interferes the Windows update.
    • > The Windows Update is blocked by the VPN or proxy.
    • > The Background Intelligent Transfer Service is disabled.
    • > Windows Update component service is
    • > The system files are corrupted.

    Since we don`t know what exactly you did tried to do, please check the methods below and post back here so we know if any of them made some change:

    Use Windows Update Troubleshooter - > Go to Update and Security, click on Troubleshoot in the left-hand pane, and select Additional troubleshooters. Then run the Update troubleshooter and check the results.

    Repair Your System Files - > Press the Windows and X keys on your keyboard and select Command Prompt (Admin).

    Run the following commands one by one:  
    DISM /Online /Cleanup-Image /ScanHealth  
    DISM /Online /Cleanup-Image /RestoreHealth  
    sfc /scannow  
    
    • > Restart the Update Service and Rename the SoftwareDistribution Folder
      Launch Command Prompt with admin privileges again and run the following commands hitting Enter after each one: net stop wuauserv
      net stop cryptSvc
      net stop bits
      net stop msiserver
      ren C:\Windows\SoftwareDistribution SoftwareDistribution.old
      ren C:\Windows\System32\catroot2 catroot2.old
      net start wuauserv
      net start cryptSvc
      net start bits
      net start msiserver Wait for the processes to complete, and then check for updates again.
    • > Delete the ThresholdOptedIn Registry Entry

    Launch the Registry Editor and navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsSelfHost\Applicability. Then remove the ThresholdOptedIn entry if it’s available on your computer.

    • > The best recommendation is to uninstall third party antivirus software and run a clean tool from this vendor to remove installed filed. If a VPN software is installed, try to un-install this software. Then reboot the machine and try to install the update again.

    -> Check whether the BITS service is running
    BITS or Background Intelligent Transfer Service is a Windows service that is required to provide updates. To ensure that this service is actually running, do the following:

    Enter Services into the search box of the taskbar, and launch the Services entry in startmenu with Run as administrator.
    After confirming User Account Control, search in the Services window for Background Intelligent Transfer Service entry.
    Launch the service and see, if errors occur. The start type should be 'Automatic (delayed)'.

    • > Check the Proxy Settings
      In some cases a proxy server is the cause for the issue. So it will be helpful to check the Internet Explorer's proxy settings.

    Press Windows key and R key together to open Run dialog, then type ms-settings:network-proxy in the box and click OK to continue.
    In the pop-up window, navigate to the Manual Proxy Setup and then change the toggle to Off under Use a proxy server.
    When it is finished, reboot your computer.

    Hope this helps with your query!


    --If the reply is helpful, please Upvote and Accept as answer--

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Reza-Ameri 16,826 Reputation points
    2022-01-24T16:06:09.217+00:00

    Take a look at:
    https://support.microsoft.com/en-us/windows/windows-update-troubleshooter-19bc41ca-ad72-ae67-af3c-89ce169755dd
    In case you are using any VPN or Proxy, try disconnect from them and try again.

    0 comments No comments