Strange things with Hyper-V 2019, ISCSI and OS reinstall

Antb 1 Reputation point
2022-01-27T17:33:51.157+00:00

Hi there. I have Hyper-V 2019 failover cluster with several nodes on it. I have multiple VM's with iscsi connects to disks. If i reinstall OS (linux or windows, no changes at VM and iqn) i have timeout errors: "Target did not respond in time for a SCSI request. The CDB is given in the dump data". Tried on several VM's and result is the same. Any suggestions?

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,530 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 39,336 Reputation points
    2022-01-28T09:02:16.417+00:00

    Hi there,

    You can try Increasing the host-side tolerance for longer latencies of SCSI requests and see if that changes anything.

    The issue might also occur because the mpio.sys driver incorrectly identifies an intermittent path failure as a device failure. Therefore, a MPIO total path failover operation is triggered incorrectly.

    A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described.

    The MPIO driver fails over all paths incorrectly when a transient single failure occurs in Windows Server 2008 or in Windows Server 2008 R2
    https://support.microsoft.com/en-gb/topic/the-mpio-driver-fails-over-all-paths-incorrectly-when-a-transient-single-failure-occurs-in-windows-server-2008-or-in-windows-server-2008-r2-7a232128-ac55-b904-b727-e1eaaa6f8889


    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments