Edge - Automatic "Sign in " to certain sites - How do I disable this?

Robin Barber 11 Reputation points
2022-01-29T02:22:15.897+00:00

Hello! I've only been an Edge user for my primary browser for about a year. Since this week, Edge is now prompting to sign on to sites on my behalf. It prompts up a picture like this:
169534-image.png

(the blacked out text is my email address listed in two rows)

The easiest way for me to reproduce this is to go to the Starbucks account page:
https://www.starbucks.com/account/signin?ReturnUrl=%2Fmenu%2Ffeatured

Chrome did this to me when it was my primary browser and there was a setting to turn it off. The setting was called 'Signing in with Google' and was in the Security settings.

This is what my settings look like in Edge. I cannot find out how to disable this totally. I don't want it 'automatically' and I don't want it to prompt for device password. I want it to stop trying to sign in - that's what my password manager is for.

169500-image.png

Windows 10, Edge 97.0.1072.76

Thank you!

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,236 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Robin Barber 11 Reputation points
    2022-01-31T03:54:00.22+00:00

    Thank you @XuDong Peng-MSFT ,

    I think this is on the right track! Here's what I see there:
    169708-image.png

    But when I go to 'manage account' I'm just directed via Edge to my Microsoft account (account.microsoft.com) with just so many settings. There's no options to change on that screen within Windows, just the 'Manage' button. Do you have any idea where to change this on the website?

    Thank you so much!

    1 person found this answer helpful.

  2. Robin Barber 11 Reputation points
    2022-02-06T20:14:57.71+00:00

    Thanks for your help @XuDong Peng-MSFT , I will add some feedback. I appreciate your assistance!

    1 person found this answer helpful.
    0 comments No comments

  3. XuDong Peng-MSFT 10,341 Reputation points Microsoft Vendor
    2022-01-31T03:38:48.627+00:00

    Hi @Robin Barber ,

    According to the image you provided, I didn't find a relevant setting or group policy, so I think this issue should be related to your Microsoft account settings.

    You can open Windows Settings and click Accounts, then click Email & accounts.
    On this panel, you can see your Microsoft account. Now you can click on the account and check if you can edit the option of your Microsoft account. Then try modifying this option and chech if this work for you. Something like this screenshoot bleow:

    169713-image.png

    Best regards,
    Xudong Peng


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.