Cannot connect to Microsoft Teams

Abdelkader 1 Reputation point
2022-01-31T13:40:26.967+00:00

Hello,

I can't connect to a teams meeting with my personal email. I get this error:

Request Id: e0509f44-41a5-470a-b044-14406b578d00
Correlation Id: 96eedd1e-826c-4cf0-bd1f-3e99704586ee
Timestamp: 2022-01-31T13:32:08Z
Message: AADSTS50020: User account 'XXX@Stuff .com' from identity provider 'live.com' does not exist in tenant 'XXX' and cannot access the application '5e3ce6c0-2b1f-4285-8d4b-75ee78787346'(Microsoft Teams Web Client) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account.

I get the same error through the web-browser client or the linux client.

This email and Microsoft account is personal and should not be linked to any organisation/tenant.

Thanks for you support

AK

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,034 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Abdelkader 1 Reputation point
    2022-02-07T09:41:09.23+00:00

    HI @JimmyYang-MSFT ,

    Thanks for your answers and your help.

    I was not able to join any meeting as external users (I tried with different external organisation). I had the same issue with the browser (chrome) or the desktop client.
    I was able to connect to my Teams account.

    I finally found a solution: I remove the cache/cookies of the browser. I didn't test yet but I have probably to do the same thing with the desktop client.

    I don't know exactly where the root issue come from but probably a conflict between azure and microsoft365:
    https://learn.microsoft.com/en-us/troubleshoot/azure/active-directory/error-code-aadsts50020-user-account-identity-provider-does-not-exist

    Anyway the issue is solve for me now.

    Thanks for your support,
    Best,
    AK