Normal.dotm file producing error becuase macros have been disabled

Joshua Reynolds 1 Reputation point
2022-02-01T04:17:40.76+00:00

169949-image.png

We have disabled Macros in word but users are now getting this error message because when the normal.dotm file loads, as its obviously macro enabled. Are we able to to change the .dotm to a .dotx file or block the error message from appearing?

It doesn't stop the blank file from loading and users going about their day just adds an annoying pop up or two on load and close of word.

Word Management
Word Management
Word: A family of Microsoft word processing software products for creating web, email, and print documents.Management: The act or process of organizing, handling, directing or controlling something.
891 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. John Korchok 4,926 Reputation points
    2022-02-01T14:52:16.533+00:00

    Sorry, Normal.dotm must remain a .dotm file. You'll have to remove the macros from it and redistribute to users.

    1 person found this answer helpful.
    0 comments No comments

  2. Charles Kenyon 2,561 Reputation points
    2022-02-01T20:37:46.91+00:00
    1. You should not be distributing Normal.dotm to existing installations. What are you trying to accomplish by doing this?
    2. This should be stored in the User Templates folder which should be a Trusted Location for macros.

    http://www.addbalance.com/usersguide/templates.htm#UserTemplates
    These days, unless it is set up otherwise, this folder would not be where users actually store their own templates.

    See also: Workgroup templates, which are intended for enterprise-level templates
    http://www.addbalance.com/usersguide/templates.htm#Workgroup

    1 person found this answer helpful.
    0 comments No comments

  3. Joshua Reynolds 1 Reputation point
    2022-02-02T06:48:21.133+00:00

    Thanks but it already has no built in macros inside the document. If the file remains a normal.dotm file it will always be macro enabled and produce the error.

    Also this is only an issue for the user we have completely disabled macro's for as this has been a request from security, thus moving back to trusted locations breaks the intended model. We have selected users with trusted signed macro's enabled they as expected do not produce this error.

    Is there any way to supress the error message from loading or showing to the user? as there is no ill effect and the users can still write to a blank document so this would be the preferred method