Office 2019 Activation Problem via ADBA

Lukas 21 Reputation points
2022-02-07T12:24:12.787+00:00

Hello,

Our company is currently experiencing problems on some clients with the Active Directory Based Activation of Office 2019 Professional Plus.

In these cases, it happens that in the account settings, as seen in image 1, it does not say "Product activated". This then leads to image 2, where you can see that it is a non-licensed product.

On our systems, Windows Scripting Host has been disabled for 2 years due to security policies.

For debugging purposes I have enabled the scripting host on the affected system so that cscript ospp.vbs /dstatus works.
A valid license is then displayed there, which is still valid for almost 180 days. As soon as this command has been sent successfully, the license also reappears in the Office product until it disappears again. I also want to mention, that i followed 259504 to ensure that the activation objects can be found with the client.

Next I ran cscript ospp.vbs /actype:1 which should perform the Active Directory Based Activation. However, these attempts are unsuccessful, as the license disappears again shortly thereafter.

Basically, we have had no problems with ADBA even though the scripting host is disabled.

Next, I looked at log files, which are located in the %temp% folder.

The following entries are noticeable there (Line 4 is the only entry related to licensing..):

02/06/2022 12:25:04.127 OFFICECL (0x1168) 0x2d8c Click-To-Run Task Telemetry apm4e Medium Task::HandleTaskStateFailed {"ScenarioInstanceId": "745185E9-790B-4CED-BB70-DA3E35AA6332", "TaskId": "77176F9C-873B-4A7D-8051-EBEB52DDE8B0", "TaskType": "UPDATEDETECTION:{77176F9C-873B-4A7D-8051-EBEB52DDE8B0}", "TaskState": 5, "Scenario": "UPDATE", "InstallID": "FD633EE8-E00A-4322-97E1-4C85B9216820", "ScenarioSubType": "Default", "SourceType": "CDN", "MachineId": "07c1f4ffe30eb24d83e01df4e29d9e47", "SessionID": "30b626eb-f146-447f-8947-73072a7ab857", "GeoID": 94, "Ver": "16.0.10382.20034", "C2RClientVer": "16.0.10382.20034", "ContextData": "Handling TaskState for task"}  
02/03/2022 17:52:57.298 OFFICECL (0x10a0) 0x3754 Click-To-Run Non Task Error aoh2l Unexpected C2R::ProcessSpawnerAdapter::SpawnProcessAndWait {"MachineId": "07c1f4ffe30eb24d83e01df4e29d9e47", "SessionID": "30b626eb-f146-447f-8947-73072a7ab857", "GeoID": 94, "Ver": "16.0.10382.20034", "C2RClientVer": "16.0.10382.20034", "ErrorCode": 1603, "ErrorType": "", "AppVErrorSource": "", "ErrorMessage": "", "ErrorDetails": "", "ContextData": "{\"Command\":\"integrator.exe\",\"Args\":\"/R /Msi MsiName=\\\"SPPRedist.msi,SPPRedist64.msi\\\" PackageGUID=\\\"9AC08E99-230B-47e8-9721-4577B7F124EA\\\" PackageRoot=\\\"C:\\\\Program Files (x86)\\\\Microsoft Office\\\\root\\\"\"}"}  
02/02/2022 08:08:50.337 OFFICECL (0x1024) 0x30ec Click-To-Run apvcy Medium ClickToRunData::GetConfigurationSetting - Failed to get value for ProPlus2019Volume.EmailAddress.  
02/02/2022 10:37:42.140 INTEGRAT (0x1548) 0x2e68 Click-To-Run Non Task Error bul13 Unexpected LicenseStore::UninstallKeys {"MachineId": "07c1f4ffe30eb24d83e01df4e29d9e47", "SessionID": "30b626eb-f146-447f-8947-73072a7ab857", "GeoID": 94, "Ver": "0.0.0.0", "C2RClientVer": "0.0", "ErrorCode": 3221356598, "ErrorType": "0xc0020036", "AppVErrorSource": "", "ErrorMessage": "HResultOnly (Failed to open Token Store , Error:0xc0020036)", "ErrorDetails": "", "ContextData": "OException: Failed open TokenStores"}  
02/02/2022 13:20:40.562 OFFICECL (0x31c8) 0x2d90 Click-To-Run Non Task Error aqo4y Unexpected ::DoRepairForApp {"MachineId": "07c1f4ffe30eb24d83e01df4e29d9e47", "SessionID": "30b626eb-f146-447f-8947-73072a7ab857", "GeoID": 94, "Ver": "16.0.10382.20034", "C2RClientVer": "16.0.10382.20034", "ErrorCode": 30102, "ErrorType": "MSIInstallationFailure", "AppVErrorSource": "", "ErrorMessage": "MSIInstallationFailure (Extensions Repair. , Error:0x643)", "ErrorDetails": "", "ContextData": "(ApiServer) - Error encountered."}  
02/02/2022 11:37:56.413 OFFICECL (0x450) 0x1e00 Experiment Liblet clfd0 Medium Office Experimentation failed to get endpoint URL  
  

How can I proceed with this problem? Unfortunately, our employee cannot use the programs like this.

Thank you very much for your answers.

Best regards,
Lukas

171921-missing-activation.png
171846-missing-activation-2.png

Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
1,610 questions
{count} votes

3 answers

Sort by: Most helpful
  1. abbodi86 2,541 Reputation points
    2022-02-07T18:19:27.89+00:00

    Line 2 is also related to licensing, because SPPRedist msi installers contain ospp.vbs and other KMS/ADBA configs

  2. Ceasar Chen_MSFT 4,356 Reputation points
    2022-02-08T07:53:04.933+00:00

    Hi,@Lukas
    Based on the description of your problem, I need some additional information from you to better solve the problem.

    1. What method is used to install the client's Office, is it ODT deployment installation or other installation methods?
    2. Since you have security policies in your domain, I would like to know if the clients have permissions to access some folders such as: %AppData%.
    3. Check whether the clients have installed Office or Windows updates recently,and try to uninstall the updates.
    4. If the KMS host is still available in the domain,please try to manually activate the affected KMS client using KMS when there are 5 affected clients.
      Manual activation using KMS requires opening CMD with administrator privileges on the client, navigating to the location of OSPP, typing cscript ospp.vbs /sethst to set the hostname, and then typing cscript ospp.vbs /act to activate Office. After manual activation, see if the problem is solved.
    5. Whether the client has installed security software, if the client has installed security software, please close security software temporarily.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. Lukas 21 Reputation points
    2022-02-09T08:17:16.787+00:00

    Hey @CaesarChenMSFT-3458 and @abbodi86 ,

    thank you for your answers and informations. Here are my answers step by step:

    1.) We deploy office using ODT.
    2.) As a user, you have permissions to access %Appdata%.
    3.) Background on this: The problem was reported with Office version 10380.20037 and a update to version 10382.20034 did no solve the problem. Office Updates seem to come as full versions when i browse the sccm folder. I think i have to reinstall an old version to test this. The Windows Updates should be no problem to uninstall.
    4.) The KMS-Host is not available anymore
    5.) It has installed Trendmicro OfficeScan, which uses behaviour-monitoring to detect threats. I think i will not get the permission to deactivate it longer than a day, but i will test this first. In the past, the virus scanner caused ospp.vbs /dstatus to timeout when i was inspecting the problem. After deactivation it worked then. Unfortunately the virus scanner did not log anything about this situation. So i think i have to test this before uninstalling the windows and office updates.

    I will post updates here as soon as possible. One more question: The scripting host is currently only enabled for troubleshooting purposes. For the activation that Office then actually performs it is completely uninvolved? It makes me a bit unsure that there is a parameter ospp.vbs /actype:1 which performs the ADBA activation.

    Best regards,
    Lukas