Azure resources not listing

Salahudheen Kappan 1 Reputation point
2020-08-20T14:33:36.41+00:00

Started my free account by last week. all was working fine till 18th Aug.
suddenly issue started that resource are not listing. Nothing showing in resource group, virtual machine, storage account etc. all resources are there under my subscription, confirmed all resources are existing in the account by listing by CLI/powershell tool.
Tried creating new resources, while creating new resource it is showing existing resource group (same existing groups are not listed under all resource/ resource group), after creation we are able to access it by clicking on notification (go to resource option), but even the new resource is not listing in the list.
Already tried :
Refresh window,
clear cookies,
open in another browser (Chrome, Explorer, Edge),
connect from different system.
confirmed no filter applied. I am new to Azure and using free account
Please guide.

Azure Web Apps
Azure Web Apps
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,322 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Salahudheen Kappan 1 Reputation point
    2020-08-21T13:09:09.993+00:00

    Issue got resolve automatically. did not made any changes but from today morning all items started listing perfect. seems like some issue at azure side.


  2. John Bevan 1 Reputation point
    2021-11-10T10:43:55.267+00:00

    FYI: A colleague just hit this exact same scenario

    • There were no filters blocking access to resources; and we could see resources under the same subscription deployed to the same location, and could see that there were no filters on resource type
    • Navigating directly to the resource's URI worked; as did running CLI and PWSH commands to list the resource.
    • However any search for the resource (e.g. browsing resources under a resource group, using Azure search, or clicking the resource type through Azure search and looking at the list of resources of that type) did not show the new resource.
    • Other users didn't have the same issue.

    Our best guess is that this is caused by some kind of replication latency between nodes; and the user with the issue just happened to be hitting a node with an older cache. We're hoping the issue resolves itself as the day progresses & this cache refreshes.

    We couldn't find a way to force that though. i.e. Logging out and back in, clearing browser cache, using incognito mode, and logging to the resource then searching for it after we've already found it, all failed to refresh these lists of resources.