Working alert but not able to view search query

Alexander Grindberg 21 Reputation points
2022-02-07T21:45:06.273+00:00

I have created a custom log search alert that works as I expect. When I receive my alert email it says under search query: "// Search query has been redacted as linked storage account is configured on Log Analytics workspace" + reference to my workspace

Label "Filtered search results" and "Search results" lead to a blank question area with the text '// Search query has been redacted as linked storage account is configured on Log Analytics workspace' / subscriptions ... '

I had imagined that the links would lead to a KQL expression that shows the results, just as it did with application insight classic.

Azure Monitor
Azure Monitor
An Azure service that is used to collect, analyze, and act on telemetry data from Azure and on-premises environments.
2,922 questions
{count} votes

Accepted answer
  1. SwathiDhanwada-MSFT 18,121 Reputation points
    2022-02-15T04:21:34.033+00:00

    @Alexander Grindberg Welcome to Microsoft Q & A Community Forum. I understand that the log query alert you have created isn't showing results when you receive alert mail. From the information you have provided, I assume you have enabled customer-managed storage account for the log analytics i.e, you are storing your collected logs in the storage account you have created.

    Also, you have encrypted your storage account data with Customer Managed Key(CMK). To disable query redaction you would need to disable CMK via linked storage.

    For more information on customer-managed storage accounts and CMK, refer this document.


0 additional answers

Sort by: Most helpful