BULK INSERT in azure sql database failling with some unknown error

Vikram D 41 Reputation points
2022-02-08T07:13:53.21+00:00

Hello All,

Getting a weird error while importing csv data into azure sql server from azure blob. Same code was working perfectly for few months but getting error now.

172146-image.png

Tried validating source files. no change in them. imported to the same destination through ADF copy task to same destination and able to successfully import. So there is no change in source and destination.

Please suggest me if where its going wrong.

Thanks,
Vikram

Azure SQL Database
{count} votes

1 answer

Sort by: Most helpful
  1. Erland Sommarskog 72,236 Reputation points MVP
    2022-02-08T23:12:32.66+00:00

    Tried validating source files. no change in them.

    You mean that you are always loading the same files? I don't think so.

    The error message makes it very clear that the file you are reading now does not match the expected format.

    Yes, I see that you have checked the file, but the error message does not lie.

    If you want more help, we need to see the statement you use, and we also need to see the file that fails. (Yes, I understand that you may not be able to share the file publically, but I'm only informing you what we need to be able to help you further. We cannot debug files, we don't see.)