Microsoft Edge is opening as a blank page on Windows Server 2012?

DavidM 1 Reputation point
2022-02-09T13:42:06.41+00:00

There are no menu options, no settings just a blank page on Windows Server 2012 R2.

It is working fine on 5 servers but not on the other 4 and they have all been installed in exactly the same way and have the same version 98.0.1108.43.

I have tried most of the usual fixes, compatibility modes, another user but it remains the same blank screen.

When in outlook any add-ins that need edge for the O365 sign in for Sync are also blank but the O365 sign in page opens when logging in for the first time and to license the products.

I have completely removed Edge, its reg keys and any left over files so a clean install.

I have also removed and re-installed MS Edge Webview2 Runtime as well.

Any suggestions would be appreciated?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,205 questions
Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,556 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Reza-Ameri 16,846 Reputation points
    2022-02-15T16:15:58.057+00:00

    Try run Windows Update and make sure you have installed all updates for Windows Server.
    Try update the Microsoft Edge.
    In case you have any extensions installed on the Microsoft Edge, try disable them.


  2. Limitless Technology 39,461 Reputation points
    2022-02-16T12:53:58.74+00:00

    Hi @DavidM

    Sometimes this happens because of a hardware overload between the browser and the device.

    First of all, you need to make Microsoft Edge work. To do this, open the task manager while Edge is running and end Microsoft Edge subtasks one by one until the Edge interface appears again.

    Once the Edge interface was visible, I went into Settings > System > Use Hardware Acceleration when available and made sure the option was OFF, if not just disable or turn it off.

    Disabling hardware acceleration must be done within Microsoft Edge, after that you must restart the device and check if it has been resolved.

    ----------

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments