Teams version bug

IBN 4,271 Reputation points

Hello Community,

The Teams desktop app on version has a bug that shows: Something went wrong You can't make or get calls right now.

Try restarting the app. That might solve the problem. When people try to join a meeting or a call. It also seems to not be able to access the microphone/speakers.

The workaround currently is to roll back to a 1.4 version however it's affecting multiple machines and doing this is not an option any more.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
8,105 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Kevinscholiers 1 Reputation point

    We installed first the new version ( but that didn't solve the issue, a roll back to V1.4.00.2781 solved the issue.
    Off course this is just temporary like already mention here with the auto-update on.

    Would be nice to have a permanent solution for this, more and more people are having this issue.

    We also tried updating the Teams client with the 'Check for update' option in Teams client but until now we didn't received any update.

    We used to following link to install the new version: and this one for the old version:
    Hopefully this can help you until the new version is ready and without issues, fingerscrossed.

    Maybe good to mention you don't need to be an admin to install this