SharePoint (on-prem) Search Results Incomplete

Dieter Tontsch (GMail) 867 Reputation points
2022-02-11T07:25:53.747+00:00

We run a SharePoint 2019 on-premises single server farm with Enterprise Search. We are crawling 3 locations, but at the moment it is about the Local SharePoint sites Content Source.
We figured out that some content is missing from the search results, it is about simple document library folders and files.

I cannot see any reason, the objects in charge are located in the same document library as all the rest we do find, they have no special permissions...
Also I could not find any errors related to these objects in the crawl log.
is there any chance to get more detailed information about this? We are a bit worried, behause one should be able to rely on his search.

Of course I can do a crawl index reset, eventually they show up after that completes, but that would be a last resort task only.

kind regards,
Dieter

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,208 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,795 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Emily Du-MSFT 41,691 Reputation points Microsoft Vendor
    2022-02-11T10:17:05.213+00:00

    @Anonymous

    Whether missing contents are in one library or in different libraries?

    Whether missing contents display in crawl logs even though there are no error messages in crawl logs?

    Please check following tips to troubleshoot the issue.

    1.Make sure the default content access account has full read permission.
    2.Make sure these files are published and approved.
    3.Make sure these files are checked in at least one time.
    4.Check whether has query rule in the content search web part.
    5.Go to Library settings -> Advanced Settings -> Reindex Document Library. Then start a full crawl in the search service application.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Dieter Tontsch (GMail) 867 Reputation points
    2022-02-11T10:43:16.527+00:00

    Thank you for your hints. But my problem was (or still is) a different one. I figured out that by some yet unknown reason no crawl happend since January 22nd this year. And due to this, all objects created after that date are obviously not part of the index.
    I started a full crawl manually, which went through successfully (Success: 94,804 / Warnings: 2,228 / Errors: 33 - which is quite ok I guess).
    After that my objects in charge could be searched.

    It where all objects from the same library though.

    The problem now is that I have to figure if next scheduled crawl tonight will start and if not, why not.


  3. Matteo Zamori 86 Reputation points
    2022-02-15T10:10:58.867+00:00

    Hi @Anonymous ,

    unfortunately there is no alert out of the box when this particular issue arrive.

    You do have however couple of options to address this point:

    • Create a custom PowerShell script which control the last crawl and fire an email if the timestamp is greater than XXX
    • Configure SP Managed Pack in SCOM (if you are using it) and finetune a rule for the Search Component
    • Evaluate a 3rd Party Tool which perform an Health-Check of SP farm
    0 comments No comments

  4. Dieter Tontsch (GMail) 867 Reputation points
    2022-02-15T11:28:22.407+00:00

    It was much simpler at the end as I thought.
    The Timer Service was not running by some reason, probably it crashed and did not restart again. After I started Timer Service the crawls, and lots of other tasks which rely on a scheduler like alerts etc., started working correctly again.
    My scheduled search crawls now run as expected.

    Thanks,
    Dieter


  5. Dieter Tontsch (GMail) 867 Reputation points
    2022-02-16T08:15:56.267+00:00

    by whatever reason I do not see the "Accept Answer" button for my own answer, so I cannot accept it as answer. Maybe you can.
    Looks like the own answer can not be accepted as answer bei the same person maybe?

    174819-image.png