A cloud-based identity and access management service for securing user authentication and resource access
Hello ,
I understand that you are having trouble logging into the Azure portal with your Microsoft account.
Error message:
"Details: AADSTS50020: User account '{EmailHidden}' from identity provider 'live.com' does not exist in tenant 'Microsoft Services' and cannot access the application 'c44b4083-3bb0-49c1-b47d-974e53cbdf3c'(Azure Portal) in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account."
Cause
There are a number of issues that can cause this error, and I would need further context to know for certain, but often this error is related to subscription access. I will go over several possible causes and solutions below.
Solution 1:
That message can occur if you have a personal "Microsoft" account using the same email address as your O365 "Work or School" account. To resolve this, go to microsoft.com/accounts using an incognito browser so that no credentials carry over, and choose the Microsoft account when logging in.
You can also try going to the direct tenant link to see if you are able to access it there: https://portal.azure.com/tenantnamehere.onmicrosoft.com
Solution 2:
Subscriptions might be located in a directory that you do not have access to. If this is the case, you will need to move the subscriptions to an account that you can access.
Solution 3
If your account is locked out of your tenant, you need to ask another global admin for that tenant to let you back in. If you are the only Global Admin for that tenant, you will need to contact the Azure Data Protection team to regain access.
Solution 4
This error message can also occur if you have a subscription that is recently expired, inactive, or orphaned. To resolve this, you will either need to claim a new Azure subscription or transfer the subscription to a new account. I would recommend opening a support case for this as you may need internal help to resolve this (depending on which issue this is).
Here is a link that also provides some helpful information on orphaned accounts. https://learn.microsoft.com/en-us/azure/devops/organizations/accounts/resolve-orphaned-organization?view=azure-devops#:~:text=An%20organization%20is%20considered%20orphaned%20when%20the%20organization,way%20of%20transferring%20administrator%20rights%20to%20another%20user.