Microsoft Photos App Print Menu Does Not Open

Heavy_C 11 Reputation points
2022-02-12T14:09:00.593+00:00

Good Morning All,

I am experiencing the exact same problem with about 10 computers on my domain. See behavior here: https://www.youtube.com/watch?v=ykDKXAzuVvQ 

When using Microsoft Photos you can usually press the printer icon, or "right click > Print" and it will open a menu to select your printer. But instead a black box with a white printer icon flashes very briefly and then disappears. There is no error message, this problem happens on computers using different versions of Windows 10 and on computers that are using completely different installed printers.

I cannot find any error messages in the event viewer about this behavior either. Any suggestions on how to fix this problem, or at least locate an error log that could explain what is going wrong in this process?

Thanks

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,538 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Heavy_C 11 Reputation points
    2022-02-22T19:41:34.517+00:00

    In case anyone else runs into this problem in the future, I have discovered a solution that fixed the problem on 7 of the computers at my workplace.

    1. I had to set the user as administrator temporarily, it would not work any other way.
    2. After the user was set as an administrator, I searched "Powershell" right-click and run as administrator. You can also right-click the windows icon in the bottom left corner, and click "Windows Powershell (Admin)"
      2b. When the computer asked for login credentials, I had to put in the username and password of the person who was having the problem, if I tried using the built-in administrator, or a domain administrator, the process would fail.
    3. Run this command

    Get-AppXPackage -allusers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    1. Once the command was run, the users were then able to open Photos and the print menu opened properly.
    2. I removed administrator rights for the users, and the printing continued to work.

    I can only recommend following these steps exactly, I tried deviating at step 2b and the issue would remain. If I was not signed in as the person with the issue, and used their login details at step 2b, the powershell command would not fix the issue. Perhaps someone who understands powershell better than I could elaborate on the problem there.

    The Powershell command selects -allusers and then has a foreach which should install the packages for every user on the PC, but in my environment it did not behave that way, the users would only receive new packages if it was their personal credentials running the command.

    1 person found this answer helpful.

  2. S.Sengupta 14,801 Reputation points MVP
    2022-02-13T01:14:52.017+00:00

    Try to reset Microsoft Photos App and recheck the issue.


  3. Heavy_C 11 Reputation points
    2022-02-13T03:15:41.097+00:00

    @S.Sengupta

    I have already tried that. I tried the troubleshooter to no avail. I also completely removed and reinstalled the AppX package with Powershell and that made no difference.

    0 comments No comments