Summary:
I understand that you were unable to restore your old domain controller, but created all of your accounts in a new domain controller and synchronized them to your tenant.
Symptoms:
After synchronizing the accounts, the UPNs all have numbers added to firstname.lastname such as john.smith1234@yourdomain.com.
Cause:
This issue occurs because the users exist in both your on-premises directory and in Azure and you have duplicate UPNs.
Solution
- ) Delete the duplicated accounts from Microsoft 365 and make sure that they are removed from the "deleted users" section of the portal. Remove-MsolUser -UserPrincipalName <duplicateaccounts@keyman .com> -RemoveFromRecycleBin
2.) Hard match or soft match the users so that Azure AD Connect knows that they refer to the same user.
There is a very good explanation of hard matching and soft matching here: https://dirteam.com/sander/2020/03/27/explained-user-hard-matching-and-soft-matching-in-azure-ad-connect/
The hard match is attempted before the soft match is attempted. If there’s no match, a new user object is created in Azure AD to correspond to the user object in the on-premises Active Directory environment.
Additional resources:
Number added to user names and email addresses when users are synced to Azure AD
Azure AD Connect: When you have an existing tenant
Azure AD Connect - Dealing with incorrectly created users post-sync
Restore deleted Microsoft 365 Hybrid User
Let me know if this helps and don't hesitate to ask if you have further questions.
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