Enable/disable smart card reader sound

Logan Burt 111 Reputation points
2020-08-22T11:24:21.227+00:00

I have a standalone personal Windows 10 computer that I sometimes use for accessing a VDI session at work. The VDI session requires a smart card, and I have installed and use a USB smart card reader for this purpose. This is working properly.

My problem is that even when I am not using VDI, I get a sound in Windows periodically from the smart card reader. This is the same sound I get when I plug in or unplug the reader from USB. I want to easily be able to access VDI with my smart card, but I don't want the annoying sound when I am not accessing VDI, that is, when my computer is idle or I am using it for my own personal purposes. I seem to get this sound whether my smart card is in the reader or not. There is nothing about a smart card under sounds in the Control Panel.

I thought I could simply disable the smart card service when I am not needing a smart card, but when I try to stop the smart card service, I get the error "Windows could not stop the Smart Card service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error." I found no errors in either the Application log or the System log, nor did I see anything in any of the smart card logs under Applications and Services Logs | Microsoft | Windows in the Event Viewer.

How do I get rid of this sound, whether by finding and disabling the sound itself or by enabling/disabling the smart card reader? Thank you very much for your help.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
6,006 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Carl Fan 231 Reputation points
    2020-08-24T07:26:38.923+00:00

    Hi,
    If you want to control the enabling/disabling a smart card device, I consider that you could try to control Smart Card Plug and Play through Group Policy.
    To disable/enable Smart Card Plug and Play in local Group Policy, follow these steps:
    Click Start, type gpedit.msc in the Search programs and files box, and then press ENTER.
    In the console tree under Computer Configuration, click Administrative Templates.
    In the details pane, double-click Windows Components, and then double-click Smart Card.
    Right-click Turn on Smart Card Plug and Play service, and then click Edit.
    Click Disabled/Enabled, and then click OK.
    Also I consider that you could try to disable USB connect sound in Sound Settings.
    https://www.windowscentral.com/how-turn-sound-notifications-windows-10
    Best Regards,
    Carl

    No comments

  2. FC-MSM 1 Reputation point
    2022-09-15T02:37:48.677+00:00

    I've seen this before, usually a reboot of your PC at home will take care of it.

    No comments