How to increase idle timeout before lockscreen activates/computer sleeps?

Cataster 641 Reputation points
2022-02-18T15:54:57.487+00:00

One of our users complained

My display times out after 30seconds or a min and I'm not able to adjust that on my end

I confirmed the user's machine is relatively new and he has windows 10 like everyone pretty much does here.

At first I thought it may be an endpoint (intune) configuration policy. However, i found no such policy with unattended timeout rules set.

I created a policy myself with unattended timeout set to 0 and applied it to all users, but after restart, he reported that the policy config didnt do anything and i also verified that with my machine as well since it still continue timing out regardless.

I removed the policy and tried other troubleshooting steps such as checking the power options and making sure screen is set to Never timeout, also checking there is no screensaver.

175894-image.png

i didnt wanna keep bothering the user at this point wasting their time with steps that arent guaranteed to work, so I tried the following commands from this article on my machine but didnt do anything!

CMD (Administrator)

powercfg.exe /SETACVALUEINDEX SCHEME_CURRENT SUB_VIDEO VIDEOCONLOCK 60 #in seconds  
  
powercfg.exe /SETACTIVE SCHEME_CURRENT  

Ive also tried changing “Console lock display off timeout” from my power plan advanced settings in control panel to like 30 minutes before the lock screen goes into a timeout but that didnt do anything either...it still locked after about 4-5 mins for me!

175893-image.png

Ive also tried enabling “Do Not Display the Lock Screen” setting from group policy personalization based on this article but that still had no effect!

175921-image.png

I then tried to change System Unattended Sleep Timeout using the following CMD elevated commands:

(On battery)

 powercfg /SETDCVALUEINDEX SCHEME_CURRENT 238C9FA8-0AAD-41ED-83F4-97BE242C8F20 7bc4a2f9-d8fc-4469-b07b-33eb785aaca0 0  

(Plugged in)

 powercfg /SETACVALUEINDEX SCHEME_CURRENT 238C9FA8-0AAD-41ED-83F4-97BE242C8F20 7bc4a2f9-d8fc-4469-b07b-33eb785aaca0 0  

but apparently there is a group policy that overrides this setting "Group policy override settings exist for this power scheme or power setting."

So I unhid the System Unattended Sleep Timeout setting using the following command in elevated CMD prompt

REG ADD HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0 /v Attributes /t REG_DWORD /d 2 /f  

Found that it is currently set to 0 anyways, yet it still times out!

175941-image.png

I have also tried the following steps from this article to no avail:

Method 1: Run the Power Troubleshooter

Power troubleshooter find and fix problems with your computer's power settings to conserve power and extent battery life

Type “Troubleshooting” in the Search bar on the desktop and press “Enter”.
In the “Troubleshooting” window, click on “View All” on the left pane.
Click on “Power”.
Click on “Advanced” and then click on “Run as Administrator”.
Click “Next” and follow the on-screen instructions to complete the troubleshooting process.
Method 2:

After running the troubleshooter, set up Screen time out settings to required time and check.

Follow the Steps below.

  1. Right click Desktop and select Personalization.
  2. Click on Lock Screen and select Screen time out settings.
  3. You can change to the required time in the drop down under Screen.

The last option was for me to try HeidiWimbush's reported solution:

Despite the screen saver set to none and wait disabled, it somehow still seems to have some effect...

175905-image.png

So i enabled "On resume, display logon" and set the time to like an hour, however, the screen still timed out after about 4-5 mins!

So I checked the screen saver settings again, and I found that it rest back to the original settings! Something is overriding the screen saver settings, but i dont know what!

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,519 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Reza-Ameri 16,826 Reputation points
    2022-02-19T16:27:07.687+00:00

    Have you tried running the GPRESULT command to see if any policy has been applied.
    You may try the gpupdate /force command to make sure policies you have changed in the Group Policy has been applied.
    Does the device contains third-party Power Management? May be from the device's manufacturer.


  2. Esteban Santana 1 Reputation point
    2022-11-11T16:40:33.977+00:00

    I have found that if your GPO is set up right and the endpoint (computer) system setting are found to be also set correctly, then it is another application that is controlling the systems settings.

    In this case I will specifically point out that if this is a Dell machine, look up and uninstall "Dell Optimizer". This application is an example of a system settings manager type of app.

    If it is a Dell machine, please uninstall on a test machine and see if the setting changed to reflect your GPO. Hope this helps.

    Esteban Santana
    365 Infrastructure Engineer


  3. MikeC 1 Reputation point
    2022-12-13T14:54:02.753+00:00

    Had the same issues on my Dell. This finally worked for me.

    Search for "Dell Optimizer".

    270137-capture1.png

    270171-capture2.png

    270172-capture3.png

    0 comments No comments