LogicApp Standard - 413 Request entity too large

Philip Appenzeller 21 Reputation points
2022-02-25T11:06:02.977+00:00

In Order to work with files bigger than 105MB i made a LogicApp Standard where i can increase the limits.

The body of my POST-Request to the LogicApp contains a large Base64 string which is about 120MB.

Request Body JSON Schema:
{
"Id": 123,
"FileName": "Test01.zip",
"FileContent": "Base64String(~120MB)",
}

I've edited the host.json as following:
177798-image.png

Similar to the answers from @MayankBargali-MSFT in this Post:
logic-app-failed-to-extract-api-data-files-exceedi.html

As you can see i tried several settings as mentioned in edit-app-settings-host-settings as well but nothing worked for me so far...

Error when testing with Postman:
177839-image.png

No actions or errors in my workflow trigger/run history...

TIA

Azure Logic Apps
Azure Logic Apps
An Azure service that automates the access and use of data across clouds without writing code.
2,711 questions
{count} votes

Accepted answer
  1. MayankBargali-MSFT 67,001 Reputation points
    2022-03-10T17:21:03.09+00:00

    @PhilipAppenzeller-8936 Apology for the delay. The HTTP request length is limited to 100 MB by the underlying platform as documented here. I have got confirmation from my team that HTTP operation settings are only applicable when you use more than 100 MB in the workflow execution for the other built-in actions and not for HTTP trigger as this cannot be changed.
    Unfortunately, you cannot send more than 100 MB to HTTP trigger. The workaround would be to upload the content to blob storage and then get the content in the logic app workflow from blob storage.

    I will work with the document team to see if we can clarify this in the configuration document.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful