az vmss list command returns empty value

Bayram Bayramli 1 Reputation point
2022-02-25T22:37:05.763+00:00

I have two resource groups in Azure, each contains one VMSS (Virtual Machine Scale Sets) and the resources are visible in Azure Portal. The problem is that, the following commands return empty output:

az resource list --subscription MySubscription -g vmss-rg
az vmss list --subscription MySubscription -g vmss-rg
az vmss list

However, running az resource list with different resource groups which doesn't have VMSS works fine. I also tested it with different Azure account and subscription, it also worked.
I have Azure CLI installed on my local machine, and I user GitBash and/or PowerShell to invoke azure cli commands. I don't use "Azure Az PowerShell module". Btw, I tried the same commands in the Cloud Shell in the portal and it worked. Actually it was working on the local machine as well about a month ago.

Azure Virtual Machine Scale Sets
Azure Virtual Machine Scale Sets
Azure compute resources that are used to create and manage groups of heterogeneous load-balanced virtual machines.
354 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Cristian SPIRIDON 4,471 Reputation points
    2022-02-26T08:53:44.873+00:00

    Hi,

    Can you update your az module?

    Hope this helps!