Print preview is failing on Chrome version Version 98.0.4758.102 (Official Build) (64-bit) [Latest]

Nico Freeman 11 Reputation points
2022-02-25T22:47:34.607+00:00

So, I have an issue where I need to check why we can't open PDF files using google chrome, I tried Brave, IE, Edge, Firefox on latest updates and is working perfectly, but after the latest update as of today we cannot view the preview, the button print is available but then we cant print.

Also tried Chrome Beta (Version 99.0.4844.51 (Official Build) beta (64-bit)) And Canary (Version 101.0.4919.0 (Official Build) canary (64-bit)) and they have the same issue.

This is a aspx, which the code behind we get the pdf as EncodeString64 we then convert it Convert.FromBase64String(pdfContent) (We get the bytes) we send the response (HttpResponse) with Buffer and BufferOutput to False the ContentType = application/pdf and we add 2 headers, the "content-length" and "content-disposition", "inline; filename=" & nameOfFile & ".pdf",
CacheControl = "no-cache", Expires = -1, and Response.BinaryWrite(pdfContentInBytes) and finally Response.Flush()

177956-image.png

178034-image.png

I don't know if anyone have encountered the same issue after this new chrome update.

Technologies: .Net Framework 4.7.2

ASP.NET
ASP.NET
A set of technologies in the .NET Framework for building web applications and XML web services.
3,317 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Yijing Sun-MSFT 7,071 Reputation points
    2022-02-28T03:00:57.977+00:00

    Hi @Nico Freeman ,
    I suggest you could check the Chrome extensions for any conflicting print extensions. Also, do you have either the Docs Viewer or the Docs PDF Viewer installed?

    Best regards,
    Yijing Sun


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our  documentation  to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Nico Freeman 11 Reputation points
    2022-02-28T17:25:23.23+00:00

    Hello YijingSun!

    This Chrome is completely new, I uninstalled and reinstalled Google Chrome completely with the latest build, without any configuration or extensions. We are using PDF Viewer.