VMware Workstation does not support nested virtualization on this host. Module 'HV' power on failed Windows 11?

Anonymous
2022-02-26T06:14:15.987+00:00

Virtualized AMD-V/RVI is disabled for this ESX virtual machine. You will only be able to run 32-bit nested virtual machines. Failed to start the virtual machine.
By default it activated VIRTUALIZATION IN BIOS level
Disable Hyper-V In turn windows features on or off windows 11
OS system : windows 11 Enterprise
CPU: AMD Ryzen 7PRO 5850U
Ram : 16GB
VMware workstation 16 pro : 16.2.2
Installed ESXI 6 and ESXI 7 hypervisor
Below is action performed in PowerShell and reboot system:
bcdedit /set hypervisorlaunchtype off and DISM /Online /Disable-Feature: Microsoft-Hyper-V
but the same problem.
Also I changed the number of CPU cores to 1.
but the same problem.
disable Device Guard or Credential Guard.
but the same problem.
After that I fixed it: Windows Security -> Device Security -> Core Isolation and make sure Memory Integrity is “Off”.
Still the problem exists .
I don't know what caused this problem ,however from windows10 it's working fine.
Can anyone suggest to me what goes wrong here ,the problem with Windows 11 or AMD Processor ?178014-amd-vissue.png178039-failedtopoweron.png

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,608 questions
{count} vote

4 answers

Sort by: Most helpful
  1. Ferdinand Pacis 21 Reputation points
    2022-03-26T13:41:50.597+00:00

    I fixed mine, Windows 11 home, Acer nitro 5 AMD Ryzen 7 by following this VMware kb

    https://kb.vmware.com/s/article/2146361

    1. Run “bcdedit /set hypervisorlaunchtype off” to disable hypervisor Close the command prompt after executing the commands and restart the system.
    2. Process to turn off virtualization-based Security:
      Below steps can be followed to turn off virtualization-based Security for Windows 10 Home & Pro:
      For Microsoft Windows 10 Pro & above: Edit group policy (gpedit)
      Go to Local Computer Policy > Computer Configuration > Administrative Templates > System
      Double Click on Device Guard on the right hand side to open.
      Double Click on "Turn On Virtualization Security" to open a new window
      It would be "Not Configured", Select "Disable" and click "Ok"
      Close the Group Policy Editor.
      Restart the system
      3.For Microsoft Windows 10 Home:
      Note: This procedure modifies the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft Knowledge Base article 256986. Open Registry Editor
      Go to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > DeviceGuard
      On the right-hand side, write a new key a. Right Click > New > DWORD (32-bit) Value b. Name this Value "EnableVirtualizationBasedSecurity"
        By default, it should be 0, Double click, and confirm the value  
      
      1. Go to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Lsa
      2. On the right-hand side, write a new key a. Right Click > New > DWORD (32-bit) Value b. Name this Value "LsaCfgFlags"
      By default, it should be 0, Double click, and confirm the value

    ![187171-image.png]1

    4 people found this answer helpful.

  2. AHansen 10 Reputation points
    2023-07-01T17:59:58.4066667+00:00

    User's image

    Tried all the above but found that turning off Memory integrity in Core isolation settings resolved it:

    Core Isolation - Memory integrity

    2 people found this answer helpful.

  3. Robert Hadley 1 Reputation point
    2022-09-06T14:44:47.303+00:00

    Alternatively, just disable HyperV in Windows features if you are not using HyperV. Reboot and try again.

    0 comments No comments