Value cannot be null. Parameter name: format visual studio 2022

John Rinaldo 1 Reputation point
2022-02-27T00:29:55.197+00:00

I can create new and work in projects, I can save them and send them to my instructor and they can open them, but whenever I try to open one of my own projects again I get this:

at System.String.FormatHelper(IFormatProvider provider, String format, ParamsArray args)
at System.String.Format(IFormatProvider provider, String format, Object[] args)
at Microsoft.VisualStudio.Shell.Design.Serialization.CodeDom.CodeDomDocDataAdapter.NotSupported(String srString, Object[] parameters)
at Microsoft.VisualStudio.Shell.Design.Serialization.CodeDom.CodeDomDocDataAdapter.get_Provider()
at Microsoft.VisualStudio.Shell.Design.Serialization.CodeDom.CodeDomDocDataAdapter.get_CompileUnit()
at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager serializationManager)
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager serializationManager)
at System.ComponentModel.Design.Serialization.BasicDesignerLoader.BeginLoad(IDesignerLoaderHost host)

VB
VB
An object-oriented programming language developed by Microsoft that is implemented on the .NET Framework. Previously known as Visual Basic .NET.
2,600 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Gdarshan 15 Reputation points
    2023-01-15T14:13:43.43+00:00

    Open visual studio code IDE>open project/solution>click on your project>open your filename.sln file then click on open

    3 people found this answer helpful.

  2. LesHay 7,126 Reputation points
    2022-02-27T09:15:33.54+00:00

    Hi

    How are you 'opening' your project? Are you loading Visual Studio and opening from the 'open recent' drop down list, or, 'open project' from the File menu in the VS environment, or, double clicking on the '.sin' file from file explorer, or, some other way. Have you tried all of these?
    You will need to show some code.
    If I asked you to fix my car because it is 'broken' and I don't show you the car, how would you get on :)


  3. JADHAV, Sandip 1 Reputation point
    2022-08-23T14:23:11.227+00:00

    I faced this issue with Node V16.17.0 and azure function core tools V4*

    I used command to trace logs

    func host start --verbose  
    

    Then I saw in logs that it's trying to download Microsoft.Azure.Functions.ExtensionBundle.zip (with some version) to specific folder. In my case it was Microsoft.Azure.Functions.ExtensionBundle.2.13.0.zip

    I manually downloaded that file and extracted zip to downloads folder.

    Then I was in logs that before downloading this zip file, It is checking if this file already exists in temp folder or sometimes in users folder. In my case it was C:\Users\<UserID>\.azure-functions-core-tools\Functions\ExtensionBundles\Microsoft.Azure.Functions.ExtensionBundle

    I just copied contents from extracted folder to this mentioned location.

    It worked.

    0 comments No comments