Can't create anchor,CloudManager_ErrorServerError:Service unavailable or unspecified error found

qfy123 6 Reputation points

Hello,I’m trying to use this demo--mixed-reality-robot-interaction-demo.I built this Unity app myself and when I want to create an anchor,I get error messages

Attempting to create anchor
CloudManager_ErrorServerError:Service unavailable or unspecified error found
Error While Creating The Anchor:Exiting
Warning:Max Proximity Light Count (2) Exceeded

The SDK version is 2.8.1.ASA config and network is all OK.I checked my azure portal,all data are 0.How can I fix this?

Azure Spatial Anchors
Azure Spatial Anchors
An Azure service that is used to build immersive three-dimensional applications and experiences that map, persist, and restore content or points of interest at real-world scale.
87 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. QuantumCache 20,031 Reputation points

    Hello @qfy123 ,
    I hope this helps with your initial query! Please give this a try with below sugestions!

    Make use of the tool to add packages : Welcome to the Mixed Reality Feature Tool

    The Mixed Reality Feature Tool is a new way for developers to discover, update, and add Mixed Reality feature packages into Unity projects.

    Download ASA packages

    Reference : Similar SO thread: This could be multiple things. For example not specifying your Azure Spatial Anchor Service details (account ID, account domain + primary key) in your project.

    Related Github Issue:

    Hello, now I finally solved all the problems, it seems to be the problem of the docker container. After I switched to ubuntu, I ran docker again, and the console output was the same as in the video. The missing part was there. Jackal can move, everything is normal. Thank you for your help these days!

    Please comment in the below section to get more help in this matter, happy to help!