Deleted storage container is still linked to routing endpoin in IoT Hub

Oetze van den Broek 121 Reputation points
2022-02-28T15:58:47.583+00:00

I am figuring out Azure IoT hub for the first time today i was having trouble with storage endpoints.

I had message routing setup to send device telemetry to a container storage, which didn't really work, or something was wrong so i decided to delete the storage container and endpoint and start over.

So i deleted the storage container, and then tried deleting the related endpoint in IoT Hub. But i wasn't able to because the container was already deleted.
I can't edit the endpoint (I think) to point to another container.

How would i fix this?

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,769 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,494 questions
Azure IoT Hub
Azure IoT Hub
An Azure service that enables bidirectional communication between internet of things (IoT) devices and applications.
1,136 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sander van de Velde 29,776 Reputation points MVP
    2022-02-28T19:52:57.99+00:00

    Hello @Oetze van den Broek ,

    I tried to recreate your steps.

    I created a storage account, I created an IoT Hub, I created an endpoint, I created a route.

    Then, I created a device and ingested telemetry. The data arrived in the storage container (please wait for a few minutes because these are stored in batches).

    Finally, I removed the storage account. Then I tried to remove the endpoint.

    The works well, if it is not in use by any route:

    178494-image.png

    That is the issue in my flow:

    178549-image.png

    Was your endpoint still in use by a route?

    Else, can you share the exception details?

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Oetze van den Broek 121 Reputation points
    2022-03-01T08:24:55.227+00:00

    Thanks for your help!

    Deleting the storage account did resolve the issuee, only deleting the container in the storage account casused the initial problem.

    0 comments No comments