When I use enhanced session with Hyper-V on vmconnect it takes me to the wrong desktop

imcdnzl 11 Reputation points Microsoft Employee
2022-03-01T09:34:01.28+00:00

I've setup a Windows 11 guest using Hyper-V on my Windows 11 machine. This works fine when I connect using Virtual Machine Connection (vmconnect) from the hyper-v manager in a standard way. I want to increase the resolution via the dialog box when I connect - this connects but just takes me to a desktop with wallpaper that only has options to choose my language, accessibility or power. When I look at the view menu on vmconnect I can see it has turned on "Enhanced session". When this is on basically it seems to be taking me to a different view than the standard desktop that I can't use. Help!!!

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,569 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,391 questions
{count} vote

1 answer

Sort by: Most helpful
  1. imcdnzl 11 Reputation points Microsoft Employee
    2022-06-18T19:06:00.887+00:00

    I found the answer elsewhere on the web that sounds weird as a solution but works - you have to turn off Windows Hello and use password authentication.

    1 person found this answer helpful.
    0 comments No comments