Custom font not emdedding in word template (but is embedding in word document)

Mike 1 Reputation point
2022-03-04T14:16:18.853+00:00

I'm a font developer trying to embed a custom font that I designed for a client into a word template. Embeds just fine when saved as a Word document, just not when it’s a template format. Seems to work fine with Adobe (Garamond, Myrid) + Google (Lato) Fonts, so not just an MS Word issue.

I’m exporting as .ttf and fsType embedding is set to ‘installable’ in custom parameters (I’ve also tried saving as ‘editable’ - didn’t work either).

I run the fonts through fontvalidator and no obvious errors.

Has anyone had any experience of this issue or might know why it’s happening and how it might be fixed?

Word Management
Word Management
Word: A family of Microsoft word processing software products for creating web, email, and print documents.Management: The act or process of organizing, handling, directing or controlling something.
902 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Emi Zhang-MSFT 22,636 Reputation points Microsoft Vendor
    2022-03-07T07:37:36.537+00:00

    Hi @Mike ,
    I suggest you refer to this support article and check if you have checked the option "Embed fonts in the file":

    https://support.mscrm-addons.com/knowledgebase/how-to-add-custom-fonts-to-ms-word-templates/

    Please note: The fonts are now saved in this template only. If you want the font(s) to be added to other templates too, you have to repeat the above steps with each template.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Mike 1 Reputation point
    2022-03-10T14:23:56.11+00:00

    Hi @Emi Zhang-MSFT ,

    Thank you for your response, however I am checking the option "Embed fonts in the file" and that's the issue - when the fonts are set to embed (as per the instructions) the fonts are embedding just fine in a word doc (.docx), but not a template file (.dotx). Any ideas why this might be?

    0 comments No comments

  3. Emi Zhang-MSFT 22,636 Reputation points Microsoft Vendor
    2022-03-14T07:22:05.703+00:00

    Hi @Mike ,
    Based on the reply of MVP Suzanne S. Barnhill, it seems that this is a by design behavior for Word template to embed font:

    https://answers.microsoft.com/en-us/msoffice/forum/all/font-embedding-in-dotx-file-not-working/5b5c20f9-872d-4735-8354-02c7768a7426

    0 comments No comments