Problem summary
Unable to log on remotely with security key and receiving the error, "Sorry, try that again. There was an issues with the server."
Cause
There is a known issue where FIDO2 cached credentials will fail after a period of time, and since you mention that this happens when you're not connected to the VPN, it sounds like this is the problem.
Troubleshooting
If you connect to the VPN (line of sight to a DC), then lock/unlock with FIDO2, does it work again?
For users without "line of sight" to a domain controller, there is an issue related to the cached credential such that sign-in will work for a while (12-48 hours or so) then fail with the error message "Sorry Try that Again. There was an issues with the server"
If you are connected to the VPN and have "line of sight" to a domain controller and FIDO2 still does not work, you can capture the authlogs data and analyze kerberos.etl to determine why that failure is occurring.
The issue is present in the latest Windows 11 builds and some Windows 10 builds.
The bug has been reported and the product team is actively working on a fix, but it is still pending. https://techcommunity.microsoft.com/t5/core-infrastructure-and-security/how-to-password-less-fido2-security-key-sign-in-to-windows-10/ba-p/1434583/page/2#comments
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