Percept Setup doesn't complete

BLAzure 1 Reputation point


Received a new Azure Percept DK delivered yesterday,

Walked through the setup. All appears working ok initially, connect to WIFI, sign in with Azure owner access, create new IOT HUB.

Enter device name and click to finalise setup.

Stuck on "We are finalizing the setup"


And eventually get "Module deployment has timed out".


Have tried several times, reset device and tried again, tried creating IOT Hub in different region all with the same issue? I can see the Azure IOT hub in the portal and the device has been registered:


I saw a post about a similar issue without resolution earlier, any ideas on how to resolve this?

Thanks in advance

Azure Percept
Azure Percept
A comprehensive Azure platform with added security for creating edge artificial intelligence solutions.
70 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. BLAzure 1 Reputation point

    Ok, I was able to resolve this. For me I found that the device was not able to be set up out of the box and first I had to do a USB update before the set up would succeed.

    For anyone else with this issue, I followed the USB update instructions here:


    • Configure the Azure Percept far enough so that the WIFI is connecting and SSH admin and password is set
    • Download the UUU tool
    • Download the latest Azure-Percept-DK version zip file and expand into directory
    • Run the UUU tool, this will say waiting for USB to connect
    • Then in an SSH window, connect to the Percept device and issue the command to set into USB mode
    • Wait for the UUU tool to update and disconnect
    • Restart the device