Blob storage static website - http 500 error

RCM 21 Reputation points
2022-03-07T08:51:26.027+00:00

Hello,

We have a problem with one of our Blob Storage accounts with the "Static Website" option enabled.

We first created it more then 2 years ago and it worked fine till 2 days ago.

Without any apparent reason the demands for the ROOT do not serve the index.html file, we have an HTTP 500 error instead. It works when we specifically request index.html.

We did not find similar situations or any relevant answer on the Internet.

We did :

  • ensure that the index.html file is well configured as index document name
  • ensure that there where no uppercase/lowercase issues
  • delete/recreate the blob storage using the same name: it worked at the beginning but the errors were back a few hours later
  • ensure that the files did not change in the meantime.

We have other storage containers configured the same way and they are working fine, but it worries us as we do not have any clue of what's happening.

Thank you.

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,491 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sumarigo-MSFT 44,096 Reputation points Microsoft Employee
    2022-03-09T05:56:03.227+00:00

    @RCM Posting Offline discussion : Location: France central

    181281-image.png

    Issue : Accessing the static website through the auto-generated public URL, returns an http 500 error.

    RCA : A new feature to support more Unicode characters in request URL is being added to Azure Storage services. As part of this feature some more URL validations were added.
    Those additional validation had a code defect: incorrect handling of a URL without a container name in the static website service. Due to this defect, valid requests have failed
    the validations. The feature was in its initial phase of deployment, and we have rolled it back immediately from entire production. The code defect has been root caused and we
    are working on a fix. More tests will be added for those new URL validations before we can deploy this feature again in production, to make sure production issues will not reoccur.

    Please let us know if you have any further queries. I’m happy to assist you further.

    ----------

    Please do not forget to 181070-screenshot-2021-12-10-121802.png and 181189-image.png wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Yong Khor Lord 1 Reputation point
    2022-04-13T04:55:46.243+00:00

    Hi @Sumarigo-MSFT , I got this error too. May I know how to resolve this? http://www.asteriskdigital.com.my/

    0 comments No comments