starting WSUS from scratch

Jeffrey Tucker 341 Reputation points
2022-03-07T14:58:47.417+00:00

hello.

i have been having issue with an inherited SCCM (MECM) system. i decided to start over WSUS. i removed the WSUS role from the server (2019). the files were on a local drive H and were detached and removed from H. i added the role back using same information for location of the SUSDB to H. role added fine. though when i did post-install tasks it fails.

"Cannot create file 'C:\Program Files\Microsoft SQL Server\MSSQL14.MSSQLSERVER\MSSQL\DATA\SUSDB.mdf' because it already exists. Change the file path or the file name, and retry the operation.Msg 1802, Level 16, State 4, Server server.domain.com,1433, Line 2"

these files do indeed exist. however they are not where the files are supposed be on H. in SQL Management Studio, the files are not referenced anywhere. the files are locked so something is using them. how do i find what SQL instance is servicing the files so i can get rid of them?

thanks

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,258 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Jeffrey Tucker 341 Reputation points
    2022-03-07T19:10:06.007+00:00

    i was able to rectify my issues at least part way. i was able to successfully complete the post-install tasks. though the SUSDB and _LOG got created in the C instead of H like I was intending. i am going to go through the move file process.

    2 people found this answer helpful.
    0 comments No comments

  2. Rita Hu -MSFT 9,626 Reputation points
    2022-03-08T02:56:12.087+00:00

    @Jeffrey Tucker
    Thanks for your posting on Q&A.

    Please follow this link to reset WSUS. It is helpful in most cases.

    Please feedback the result for us if there are any updates of the case.

    Thanks for your time and effort to resolve this issue. Don't hesitate to inform me if there are any questions or updates.

    Have a great day.

    Regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

  3. Rita Hu -MSFT 9,626 Reputation points
    2022-03-22T07:11:34.433+00:00

    @Jeffrey Tucker
    To remove WSUS completely, you need to:

    Remove the following server roles and features through Server Manager:
    Roles: Windows Server Update Server

    features: Windows Server Update Services Tools(at Remote Server Administration Tools -> Role Administration Tools)

    Follow the wizard prompts to complete the deletion. Then restart the server.

    After the server is restarted, manually delete the folder or file of the following path:
    C:\WSUS (this depends on where you choose to install WSUS)

    C:\Program Files\Update Services

    Delete database files
    If you use SQL Server Management Studio to delete a database, you can try as follow.

    In Object Explorer, connect to an instance of the SQL Server Database Engine, and then expand that instance. Expand Databases, right-click the database to delete, and then click Delete. Confirm the correct database is selected, and then click OK.

    If you use a WID database, it is recommended to delete the following path folders:

    C:\Windows\WID

    In the IIS Information Services (IIS) Manager, manually remove the WSUS Administration site. Then restart the server.

    Bset regards,
    Rita


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments