Group Policy not applying to laptop connected to VPN

GRattu 1 Reputation point
2022-03-08T16:28:16.62+00:00

I haven't been able to get Start Layout GPO to work for laptops that connect over VPN. I've set up my VPN to connect before I logon with my user account but for whatever reason the GPO is still not changing my settings.

I know that I set up my Start Layout file correctly because when I run the Import-StartLayout command with the .xml I've made it makes the changes to my Start Menu and to my Taskbar. I've also been able to make a Local Group Policy and I can see my my Start Menu and Taskbar changing when I log out and log back into my account. I'm fairly certain my GPO is set up correctly because computers that are connected locally to our domain controller and aren't having to connect by VPN are able to update and apply the Start Menu .xml file.

For reference I used the template here as a base for my .xml https://learn.microsoft.com/en-us/windows/configuration/configure-windows-10-taskbar
I also followed this when creating my GPO https://learn.microsoft.com/en-us/windows/configuration/customize-windows-10-start-screens-by-using-group-policy

Bit of a weird one, hoping someone has experience with this.

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,857 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Limitless Technology 44,011 Reputation points
    2022-03-09T09:23:30.157+00:00

    Hello @GRattu

    In this case, since the policy is applying correctly to on premise computers, I would recommend looking in the next:

    B) Network not ready during the synchronous load of policies:
    Set the policy to “Always Wait for the Network at Computer Startup and Logon” as Enabled for the VPN computer group
    Policy path: "Computer Configuration \ Administrative Templates \ System \ Logon \ Always wait for the network at computer startup and logon"
    Reference: https://learn.microsoft.com/en-us/previous-versions/windows/desktop/policy/logon-optimization

    Hope this helps with your query,

    --
    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. GRattu 1 Reputation point
    2022-03-10T17:53:22.927+00:00

    I gave both of those a try and I'm unfortunately still seeing the same behaviour. The Slow Link Detection was not configured by default, I changed that to Disabled anyway. I also set the Always Wait for the Network at Computer Startup and Logon to Enabled.

    0 comments No comments