Can't install VS 2019 or 2022

Bruce Krell 1 Reputation point
2022-03-10T20:50:41.85+00:00

I can't install either VS 2019 or VS2022. I had previous installations. I uninstalled, cleared the install folders, removed keys from the registery, rebooted, downloaded the latest versions. Tried to install. Get same error message for both. Some assembly can not be found. Gives me a guid. What do I do here?

Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
976 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Bruce Krell 1 Reputation point
    2022-03-11T03:53:53.91+00:00

    I did what you said, and tried to install VS Community 2019 and 2020.

    Won't let me install.

    I ran collected and have the zip file on drop box

    Here is the link: https://1drv.ms/u/s!Aqh6ghQEpiW_gTjd4STzemqBrrzf?e=dluyqw

    0 comments No comments

  2. Anna Xiu-MSFT 26,566 Reputation points Microsoft Vendor
    2022-03-11T10:17:51.87+00:00

    Hi @Bruce Krell ,

    From looking at your logs, I found the error message:
    Failed to do machine state detection due to error: Could not load file or assembly 'System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The module was expected to contain an assembly manifest.

    It seems to not find the System.Data.dll or its dependencies. The dll is related to .NET Framework.
    Please try to use the Microsoft .NET Framework Repair Tool to repair your .NET Framework.
    https://www.microsoft.com/en-us/download/details.aspx?id=30135

    Sincerely,
    Anna
    *
    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Bruce Krell 1 Reputation point
    2022-03-17T06:16:20.957+00:00

    I did all this. Still get the same error message.
    Thanks for trying to help.

    It appears that somehow the installer thinks that a later
    version has been installed.