Azure Kudu console not opening - 503 unreachable

Duraikannu Jeyamani 6 Reputation points
2022-03-11T05:56:13.117+00:00

Hi , I have hosted my .NET web application in Azure app service, After that I added the site extension to profile that web app. Then restarted the Azure app service now I couldn't access the Kudu Console but can access the web app.

How to trouble shoot this ?

Thank you.

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,045 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ajkuma 22,926 Reputation points Microsoft Employee
    2022-03-11T20:39:42.813+00:00

    DuraikannuJeyamani-6375, To better assist you on this, what specific site extension did you install?

    Kindly see if scaling up/out helps. (if you haven't done already)
    As I understand from your issue description, the issue started after installing the site extension - As a quick step/to isolate the issue, you may uninstall/delete the site extension installed (from Azure Portal > Extensions blade – since you’re able to access the WebApp just fine), and then see if it helps. [screenshot below]

    Just to confirm, is the WebApp on ASE (App Service Environment?) ILB ASE or Public ASE?

    Capture a network trace/F12 or Fiddler trace to see if it provides any pointers.

    If your app integrates with your VNet, it uses the same DNS server that your VNet is configured with. By default, your app won't work with Azure DNS private zones.
    https://github.com/MicrosoftDocs/azure-docs/blob/main/includes/app-service-web-vnet-regional.md#azure-dns-private-zones

    To work with Azure DNS private zones, you need to add the following app settings:
    WEBSITE_DNS_SERVER with value 168.63.129.16
    WEBSITE_VNET_ROUTE_ALL with value 1

    If feasible, kindly try capturing the git http verbose output, as outlined in this doc.
    Kindly let me know how it goes, I'll follow-up with you further.

    182250-image.png

    0 comments No comments