"visual studio 2019" You need to allow cookies to use this service

David Rodney 6 Reputation points
2022-03-15T06:19:05.973+00:00

I searched 8 forums and most questions on this were closed so I'm posting it here. I dug around all my browsers lowering my security to fix this problem, when the actual solution was tucked away in options, but not under "Web Browser".

  1. Open Visual Studio 2019
  2. Under Tools Select Options
  3. Select the options category "Environment"
  4. Select sub-option "Accounts" (NOT "Web Browser")
  5. Under Sign-in options there's a drop-down for authenticating accounts.
  6. Switch from "Embedded browser" to "System web browser"
  7. Hit OK and it should link up normally.

The solution was posted by Godrej Wadia last year but the png illustrating the window broke, hence the painstaking detail.

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
5,669 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Larry Clarke 0 Reputation points
    2023-08-30T17:49:49.5466667+00:00

    Works the same for Visual Studio 2022.

    0 comments No comments