Hyperlink to Excel Workbook on Sharepoint does not work when emailed using Outlook.

Prem Kiran 1 Reputation point
2022-03-15T16:26:09.81+00:00

I have two hyperlinks.

  1. has the full url with spaces as they appear in the folder name and in the filename
  2. has the spaces replaced with "%20"

When the link is pasted into Edge both of the links will open the Excel Workbook and a click on the "Edit Workbook" will put the workbook into edit mode.
183345-image.png

All well and dandy.

When the either of the links are sent in an email via Outlook the Excel workbook opens but clicking the "Edit Workbook" gives an error.
183337-image.png

Therefore, there is nothing wrong with the links to the file when pasted into the browser.
When link is accessed from within outlook something lock the file.
There are no other users accessing the file. Sauf moi.

What am I doing wrong?

Excel Management
Excel Management
Excel: A family of Microsoft spreadsheet software with tools for analyzing, charting, and communicating data.Management: The act or process of organizing, handling, directing or controlling something.
1,661 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Hua-MSFT 27,551 Reputation points
    2022-03-16T08:34:37.377+00:00

    Hi @Prem Kiran

    Welcome to Q&A forum ~

    > When the either of the links

    How did you send the link via emails?
    Such as insert the hyperlinks manually or send the sharing link via Outlook.
    Basde on my test, the sharing link seems not to include the "%20"(Space).

    As you can edit this file on Edge, I sugget you go to document library, click Gear Icon > Library settings > Advanced settings > Under Opening Documents in the Browser section, change the radio button to "Open in the browser".
    183654-microsoftteams-image.png

    Besides, I would also suggest you add the URL into Excel trusted location via going to File > Options > Trust Center > Trust Center Settings > Trusted Locations > Add new location.
    Then go to go to File > Options > Trust Center > Trust Center Settings > Protect View > disable Protected View temporarily via unticking 3 options.
    183625-capture46.jpg

    If you have security software on machine, please quit temporarily to check this issue,


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.