Email block country level on Exchange 2016

Innocent Heartvoice 286 Reputation points
2022-03-16T05:38:21.783+00:00

Some time ago our Exchange 2016 was hit by a massive spam attack and for that we blocked emails from the country. Some of our users are now travelling to the UK and we want to allow them secure access to their email on Outlook.

Please suggest a job for this situation.

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,939 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,386 questions
0 comments No comments
{count} votes

Accepted answer
  1. Aaron Xue-MSFT 2,586 Reputation points Microsoft Vendor
    2022-03-17T03:19:56.707+00:00

    Hi @Innocent Heartvoice ,

    Based on my knowledge, you couldn’t block foreign country emails through EAC. You need to block the email from the Firewall.

    According to my search, you could block the country emails in the outlook, and you could add trusted users or domain to the safe senders.

    Here’s the document for you reference.
    https://support.microsoft.com/en-us/office/block-a-mail-sender-b29fd867-cac9-40d8-aed1-659e06a706e4?ui=en-us&rs=en-us&ad=us


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


1 additional answer

Sort by: Most helpful
  1. Andy David - MVP 142.7K Reputation points MVP
    2022-03-16T11:15:32.06+00:00

    Blocking emails from a country wont prevent authenticated users access to their mail or prevent their ability to send and receive.
    Is it not working?

    0 comments No comments