MS Access compact and repair Could not use ; file already in use. (Error 3045) JAMIII

Jim Manson 1 Reputation point
2022-03-17T10:47:09.577+00:00

When I try to compact and repair I get the "Could not use; file already in use error. I recently upgraded to Windows 11 because I found in one of the solutions that noted it would eliminate the "MS Access compact and repair Could not use ; file already in use. (Error 3045) ". Well, it didn't. Help. I apologies if this is a duplicate question. I could find the original question I submitted.

Access Development
Access Development
Access: A family of Microsoft relational database management systems designed for ease of use.Development: The process of researching, productizing, and refining new or existing technologies.
837 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Karl Donaubauer 1,651 Reputation points MVP
    2022-03-17T15:22:44.743+00:00
    0 comments No comments

  2. Tom 1 Reputation point
    2022-04-24T17:49:39.313+00:00

    I too was getting the same error. I have several MS Access databases and I was getting error 3045 any time I attempt to use compact and repair. I am using Office version 2203 (Build 15028.20228 Click-to-Run) and running under Windows 10. Since my Office version is more recent than the fixed version that Karl referred to, I wondered why I was getting this error.

    I did some more Internet searches and found https://www.devhut.net/cannot-compact-and-repair-access-database-file-already-in-use/. Daniel Pineault reports that the issue is due to McAfee Antivirus and that a workaround that has helped some people is to add the MS Access executable to the exclusion list of files not to check. That worked for me.

    0 comments No comments