How to delete a failed model in form recognizer

Emily Harper 111 Reputation points
2022-03-18T09:57:31.427+00:00

Hi there!

I attempted to train a model in form recognizer studio and it let me, then coming after the fact to tell me that it could not train due to there only being 3 documents (surely it would be better to say this up front rather than letting the training attempt anyway before erroing...)

However, I now have a failed model stuck in my models list in form reconigzer studio. The delete button is greyed out so I cannot remove it.

When I do list models, it is not there due to it being in failed. When I run the API to delete model, it says the model does not exist. I re-trained the model with 5 documents and I then had the correct model in the list, with the same name. But the old one remains there. I tried again to delete it, but it just removes the working one. I have no way to get the stuck model out of the list.

Thanks in advance if you can advise how I can get this to go away.
Emily

184554-image.png

Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,431 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,434 questions
{count} vote

4 answers

Sort by: Most helpful
  1. Ukkie 10 Reputation points
    2023-02-07T13:08:39.07+00:00

    We're now February 7th 2023. I'm expiriencing still the same issues: I can't delete a failed model.

    2 people found this answer helpful.

  2. GiftA-MSFT 11,151 Reputation points
    2022-03-28T19:14:32.353+00:00

    Thanks for your feedback, I've forwarded the feedback to the product team. The product team are continuously working to improve the tool. Since the tool is still in preview, there's currently no ETA on when this issue will be resolved. Feel free to share the feedback on ideas portal so others can upvote and enable the product team prioritize resolution of this issue. Sorry for any inconvenience.

    0 comments No comments

  3. Yardy, David 1 Reputation point
    2023-03-10T18:19:43.08+00:00

    I never did get it resolved. I had to remove my fields.json and start over re-mapping. Adding fields, testing, adding more etc. and keep doing. Something is not quite right and not sure what it is.

    0 comments No comments

  4. Maui Rivera 240 Reputation points Microsoft Employee
    2023-06-02T07:01:49.27+00:00
    0 comments No comments