Startup Applications Automatically Getting Disabled

Abdullah Marfadi 11 Reputation points
2022-03-21T01:01:24.813+00:00

So, recently I noticed that some applications I enabled to startup don't start up on boot anymore. I have no clue as to why this is but I noticed in Task Manager whenever I enable them again and restart/shut down my computer and it just goes back to being disabled. This only applied to Microsoft Store (UWP) apps and not non-UWP applications. Is it because of a Windows 11 bug or is it something else?

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,427 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Reza-Ameri 16,836 Reputation points
    2022-03-21T15:16:33.177+00:00

    This is not expected behavior, so you may try run Windows Update and download and install all updates.
    Open start and search for feedback and open the Feedback Hub app and report this issue.
    Try perform a Clean Boot and see if the problem persist?
    Take a look at:
    https://support.microsoft.com/en-us/topic/da2f9573-6eec-00ad-2f8a-a97a1807f3dd?msclkid=c501a67ba92911ec839b4800966c417e
    If not enable service one by one to see which one causing this issue.


  2. Limitless Technology 39,436 Reputation points
    2022-03-25T15:45:07.5+00:00

    Hi @Abdullah Marfadi

    If you're in Windows 11 and you're having problems with an app from Microsoft Store, consider these updates and fixes.

    First, sign in to your Microsoft account. Next, work through these possible solutions in the order presented.

    Make sure Windows is up to date
    Select Start > Settings > Windows Update > Check for updates. If there is an available update, select Install now.

    Make sure that your app works with Windows 11.
    For more info, see Your app doesn't work with Windows.

    Update Microsoft Store
    Select Start, then from the apps list, select Microsoft Store. In Microsoft Store, select Library > Get updates. If an update for Microsoft Store is available, it will start installing automatically.

    Troubleshoot games
    If you're having issues installing a game, see Troubleshoot game installations on Windows.

    Repair or reset your apps
    See Repair or Remove programs in Windows.

    Reinstall your apps
    In Microsoft Store, select Library. Find the app you want to reinstall, and then select Install.

    I do hope this answers your question.

    Thanks.

    --
    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  3. Karen Tam 160 0 Reputation points
    2023-08-09T10:34:16.21+00:00

    I have the same issue, have done every step suggested above but issue still persists.

    0 comments No comments

  4. Keith Lewis 0 Reputation points
    2023-10-02T11:20:13.7466667+00:00

    Me also! In this case it is a password app. Tried all the solutions...still the same... About time this was investigated and fixed...

    0 comments No comments