Multi Flat File Delimiter Problem

It Journalist 21 Reputation points

Hi all,

I have a problem on reading multi flat file. My connection manager does not separate some of the entries.

To clear, my row delimiter is {CR}{LF} and column delimiter is semi column ( ; ) . It reads and separates some of the lines. However it does not separate one or two lines per file. Flat file sources are standard. All are semi column separated. how can I overcome this?

SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,467 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Olaf Helper 41,411 Reputation points

    However it does not separate one or two lines per file

    Sorry, but I don't understand what you mean with this and without having the source data file it's difficult to guess.

    Please post a sample file with some lines that works and that don't work.

  2. ZoeHui-MSFT 33,626 Reputation points

    Hi @It Journalist ,

    I could not clearly understand your issue, if possible, could you post some images or sample data to describe the error?

    In addition, if a Multiple Flat Files connection manager references multiple files, all the files must have the same format.

    Make sure that your multiple files have the same format.




    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. It Journalist 21 Reputation points

    Dear @Yitzhak Khabinsky ,

    Thanks for your comment. I have done a light research for this and found a solution at .. The summary of the problem is that

    Some lines, as you have written, may contain null terminators or may end with {CR}{LF},{CR} or {LF} and this is cannot be catched by eye.