Unable to use Copy Model on v3 preview 2

Emily Harper 111 Reputation points
2022-03-23T16:46:35.357+00:00

We have done a lot of copy model and copy model authorization on v2.1 but our new models have been made on v3 preview 2. We have changed over onto the new URIs but are having a lot of issues.

Authorize Copy
This worked fine. We got back the usual response to be used on the copy model. Below is an example of us creating a test model in our UAT environment. We ran the URI on the target system, creating the target model.

186232-image.png

Copy Model
We then did a copy model from the source URI in dev and pasted the body in from the authorize copy. It comes back saying "404 resource not found"

186177-image.png

List Models
I ran this to see if I could see the models but I cannot. I see that the migration guide says that only successful models are here now and any in progress or unsucessful are not here. It suggested using List Operations to see those in progress.

List Operations
I ran this at the target location but I got back a blank response
186166-image.png

If I try re-send the Copy Authorization, it says my model already exists and it can't make another one. So I know the model is there somewhere, I just can't see it and I can't copy into it. Why is is that 2.1 works perfectly but v3 preview 2 just won't let me do what I need? Am I doing something wrong? I am following the same process as before just using the new URIs. The migration guide and v3 preview 2 API guide have been followed and I copy and pasted the URIs from there and my resource names from Azure.

186160-image.png

Thanks!
Emily

Azure AI Document Intelligence
Azure AI Document Intelligence
An Azure service that turns documents into usable data. Previously known as Azure Form Recognizer.
1,443 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,449 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Harper 111 Reputation points
    2022-03-28T14:07:44.183+00:00

    I have solved the problem!

    In the migration guide from 2.1 to 3, the POST for copy to has the URI containing ":copy-to" (https://learn.microsoft.com/en-us/azure/applied-ai-services/form-recognizer/v3-migration-guide#changes-to-copy-model)

    187594-image.png

    However, if you go to the v3 API guides it is ":copyTo". I removed the dash upon noticing that the two guides disagreed, but didn't realise it was case sensitive. Once I stopped using copy-to as per the migation guide or copyto and went to copyTo, it is working now. You may wish to update the migration guide.

    https://westus.dev.cognitive.microsoft.com/docs/services/form-recognizer-api-v3-0-preview-2/operations/AnalyzeDocument