SharePoint 2016 site settings 404 file not found error

Ross, Murray 1 Reputation point
2022-03-24T11:59:29.58+00:00

Hi,

I'm currently configuring my new SharePoint, and after creating a view, all of a sudden the SharePoint has started to throw a '404 file not found' error when I try to click the button for 'site settings'. However, when change the URL from 'https' to 'http', it lets me access the settings on an unsecured connection. Is there a way to remedy this so it accepts the secure https connection?

Any help would be great!

Murray

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,807 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. CaseyYang-MSFT 10,321 Reputation points
    2022-03-25T05:56:40.31+00:00

    Hi @Ross, Murray ,

    You could try following steps to change a SharePoint web application from HTTP to HTTPS.

    1.Add HTTPS Binding for the SharePoint Web Application

    IIS Manager > select your web application > Bindings... > Adds...

    2.Configure Alternate Access Mapping

    Central Administration > Application Management > Configure alternate access mappings > Edit Public URLs > the HTTPs URL in any of the Zone like “Intranet”

    For Reference:

    How to Change a SharePoint Web Application from HTTP to HTTPS step by step
    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.