Indexing of a virtual folder (cloud files API) impossible on Windows

Biva 6 Reputation points
2022-03-25T11:51:12.597+00:00

Hello,

I use Nextcloud which is using the cloud files API (Cloud Sync Engine). In Windows indexing options, I'm usually able to choose which folder to index or not. But I can't see these "virtual" folders (the ones using the cloud files API) when I click on Modify to choose which folder should be indexed. I tested this on Windows 10 and 11.

The content is not downloaded on my laptop, so I understand that the indexing of the content is not possible. But at least, how can I index the filenames?

Would you have a solution?

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,602 questions
0 comments No comments
{count} vote

4 answers

Sort by: Most helpful
  1. Limitless Technology 39,461 Reputation points
    2022-04-01T10:29:44.853+00:00

    Hi @Biva

    Maybe you need to check the file types that can be indexed and see if they differ from the "virtual" folders. For a list of file types that can be indexed, go to the Indexing Options control panel page and select Advanced > File Types.

    The indexing process happens in three stages controlled by a Windows Search component called the gatherer.

    In the first stage, the gatherer adds URLs to queues. The URLs identify items to be indexed, and the queues are merely prioritized lists of URLs. In the second stage, the gatherer coordinates other Windows Search and third-party components to access the items and collect data about them. Finally, in the third stage, the data collected is added to the index.

    The files in your virtual folder might miss any one of the above stages and that might be the reason or them to be not shown in indexing options.

    Hope this resolves your Query!!

    --
    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments

  2. Limitless Technology 39,461 Reputation points
    2022-04-01T10:29:45.06+00:00

    Hi @Biva

    Maybe you need to check the file types that can be indexed and see if they differ from the "virtual" folders. For a list of file types that can be indexed, go to the Indexing Options control panel page and select Advanced > File Types.

    The indexing process happens in three stages controlled by a Windows Search component called the gatherer.

    In the first stage, the gatherer adds URLs to queues. The URLs identify items to be indexed, and the queues are merely prioritized lists of URLs. In the second stage, the gatherer coordinates other Windows Search and third-party components to access the items and collect data about them. Finally, in the third stage, the data collected is added to the index.

    The files in your virtual folder might miss any one of the above stages and that might be the reason or them to be not shown in indexing options.

    Hope this resolves your Query!!

    --
    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments

  3. Biva 6 Reputation points
    2022-04-01T11:22:20.883+00:00

    Hello @Limitless Technology ,
    Thank you but this doesn't answer to my question unfortunately: the problem is that I can't even include the folder in the indexing. And the files in the folder are normal files: pictures, docx, xlsx, ...


  4. Antonio L 0 Reputation points
    2024-01-06T09:14:44.3233333+00:00

    I also have the same problem with Windows 11 22h2 while with Windows 10 it worked fine for me.

    I use Apple's iCloud and I have set that the files must be resident on my PC

    The Icloud folder is located \users\Antonio\Icloud

    This folder does not appear in the indexing settings so it cannot be indexed.

    I have the problem that accessing this folder always takes about 7/8 seconds (my pc (i5-14600 32gb ram ddr6 nvm2)

    The strange thing is that if I open the subfolders from the left column of file explorer they open immediately while opening them from the main window takes a long time.

    Opening a simple 5kb text file takes 7/8 seconds.

    Can you help me?

    0 comments No comments