GPO for lid close action not applying

Erik Gisslén 21 Reputation points
2022-03-25T15:07:31.857+00:00

I have a GPO with a power plan (Computer Configuration\Preferences\Control Panel Settings\Power Options\Power Plan) to set the lid close action to "Do nothing". On the clients the power plan is applied according to gpresult, and I can see the correct power plan name in control panel. The power settings for when to turn off the display and when to put the computer to sleep is correct, but the settings for the lid and power buttons do not get applied correctly. They are all set to "Sleep" instead of "Do nothing". I can change the settings manually, as expected and wanted, but the default settings should be "Do nothing".

My test computer has a fresh install of Windows 10 20H2, installed using a SCCM task sequence.

Any ideas why these settings are not applying as expected?

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,920 questions
0 comments No comments
{count} votes

Accepted answer
  1. Reza-Ameri 16,846 Reputation points
    2022-03-26T14:28:01.903+00:00

    Try run Windows Update and download and install all updates.
    Try perform gpupdate /force command to make sure your system is fully implemented the policy.
    Check and if there is any firmware available, make sure update them.
    Try open start and search for feedback and open the Feedback Hub app and report this issue.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Erik Gisslén 21 Reputation points
    2022-03-30T12:16:52.677+00:00

    Thanks for the response Reza-Ameri!

    Windows is fully updated and I've tried gpupdate /force several times but it didn't help.

    I exported a power management report from SCCM and it said that the settings in the GPO was actually working on the computer. But in Control Panel it still said "Sleep" on all settings. When I had physical access to a computer I tested what really happens when the lid is closed, and to my surprise nothing happened. When I manually set it to "Do noting" and then back to "Sleep" it went in to sleep mode when I closed the lid. So it seems like the GPO is setting the correct settings from the beginning but Control Panel is showing the wrong setting (all set to "sleep"). This made me a bit confused. Maybe it's some kind of bug.

    I'll accept your answer "...report the issue" as correct.

    Thanks!

    0 comments No comments