[SQL] [MDT] SQL server does not exist or access denied

Yohan Can 41 Reputation points
2022-03-25T15:02:17.563+00:00

Hello,

I'm studying in school and looking to associate SQL Server Express with MDT (Microsoft Deployment Toolkit) to get custom install deployment.
Note that everything is working well normaly without SQL Server Express, my standard conf on MDT is okay.

I have 2 servers :

  • FRPA-DC01 on Fujitsu.local domain which is Domain Controler + DHCP
  • FRPA-WDS01 on Fujitsu.local domain which is WDS + MDT

Both servers are connected with the admin domain account FUJITSU\administrator.
After verifying standard WDS + MDT is working :

  • I installed SQL Server Express 2017 (also tried with 2019)
  • I openned 1433/1434 TCP and UDP port In and Out (also tried to disabled firewall)
  • SQL Server and SQL Server Browser services are Enabled
  • Named Pipes is Enabled
  • On MDT i created a Database following many simple tutorials

But when i boot my client he's trying to contact my SQL Server and he got this error :

ZTI error opening SQL Connection: [DBNETLIB][ConnectionOpen (Connect()).]SQL server does not exist or access denied (-2147467259)    ZTIGather   25/03/2022 06:54:01 0 (0x0000)  

You can check my SQL Server =>

186908-error-sql.png

Do you have an idea ?
Thank you,
Regards.

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
13,067 questions
Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
845 questions
Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
2,040 questions
0 comments No comments
{count} votes

Accepted answer
  1. Martin Cairney 2,246 Reputation points
    2022-03-27T10:42:50.467+00:00

    Your SQL Express has installed as a Named Instance. By default this does not listen on Port 1433 so your firewall rules that are set for that access will not be permitting traffic through.

    You can update your SQL deployment to set the port to 1433 by following the instructions here

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Yohan Can 41 Reputation points
    2022-03-27T21:27:48.33+00:00

    Hello Martin,

    Thank you i checked that and i did it !
    But just to know, what's was wrong with my previous configuration ? Because i didn't did more than enabled Named Pipes services and selected it also on MDT as nobody did more on many tutorials. Maybe i had to configure something else ?

    Thank you again.