question

SveinTrulsrud-0378 avatar image
0 Votes"
SveinTrulsrud-0378 asked TrentHelms-MSFT answered

Does the Azure Stack HCI preview support installing on physical servers?

We are trying to install the preview on Lenovo MX1021 certified nodes. The install program says it cannot install to the M.2 RAID drive which is the boot media on these systems.

azure-stack-hci
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MattMcSpirit-MSFT avatar image
0 Votes"
MattMcSpirit-MSFT answered

Hey - could you confirm, the error is during the setup phase, and the M2 RAID drive can't be found, or is the M2 drive found, and when you select it, there's an error?

If it can't locate the drive, first, download the storage driver from Lenovo, and put it on a USB stick attached to the server. When you get to the "Where do you want to install..." page of the install, press Shift + F10 and navigate to the USB stick and install the driver using PnPUtil. From there, the drive should be visible and your installation should be able to continue.

If you can find the drive, and yet still get an error, can you provide more info on the error, screenshot etc?

Thanks!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SveinTrulsrud-0378 avatar image
0 Votes"
SveinTrulsrud-0378 answered

Thanks. We can see the drive, but Setup says it is not bootable. We tried to load the latest drivers, but it made no difference. We are now installing WS2019 Datacenter, and that seems to work fine.
21222-azure-stack-hci-install-error.jpg



5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MattMcSpirit-MSFT avatar image
0 Votes"
MattMcSpirit-MSFT answered

Thank you for this extra info. This should work fine for both WS2019 and AzSHCI Preview, so may be a bug - I'll raise this internally and get back to you. Thank you!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TrentHelms-MSFT avatar image
0 Votes"
TrentHelms-MSFT answered TrentHelms-MSFT commented

Hello,

If you remove all partitions from the disk you are attempting to install to and allow the setup to recreate them, does this make any difference? Also, as a troubleshooting step, could you try to 'hide' or temporarily remove the additional disks in the system to see if this makes a difference?

Best Regards,
Trent

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

There were no partitions on Drive 0 when we started. I created that partition to see if it helped. When we installed Server 2019, we had to remove the partition and let setup create them.

Also, we did have to load the RAID driver from USB when we installed Srv2019.

0 Votes 0 ·

Hello,

Thank you for the additional information. The setup procedure for Azure Stack HCI should be pretty much the same as Server 2019. Did you try loading the RAID driver within the AzSHCI setup as well?

Best Regards,
Trent

0 Votes 0 ·
CarmenCrincoli avatar image
0 Votes"
CarmenCrincoli answered SveinTrulsrud-0378 commented

It would also be useful to know more about the disk controller. I assume these M.2 devices are SATA and not NVMe, so knowing the RAID adapter model would be most helpful.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It is a SATA RAID adapter for M.2 drives, Marvell 88SE9230 6 Gbps SATA controller.

0 Votes 0 ·
SveinTrulsrud-0378 avatar image
0 Votes"
SveinTrulsrud-0378 answered

Hi. Install worked fine once we booted from a USB key (UEFI boot), instead of remote media (which only worked in Legacy mode).
Thanks for your help.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

TrentHelms-MSFT avatar image
0 Votes"
TrentHelms-MSFT answered

Hello,

Thank you for the update and confirmation. I am glad to hear you were able to get the installation working. Please let us know if we can be of further assistance.

Best Regards,
Trent

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.